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1 Creating Forms From
Scratch

This section covers how to create a data entry form from scratch that doesn’t connect to a database. 
Users can save the values in the form, and print the form. 

You can also create a PDF version of the form to make available on the web. Users can’t save 
values in that form but they can fill it out and print it.

Creating a Simple Form
1 Start OpenOffice.org and choose File > New > Text Document.
2 You’ll need to bring up the toolbars containing the tools you need. Choose View > Toolbars > 

Form Controls. This is the toolbar that lets you choose specific fields such as check boxes and 
text fields. It looks different depending on your operating system; use the tooltips to ensure 
you’re getting the field you want by moving your mouse over each icon and reading the tip 
that appears.

3 You want to be in form design mode, not form use mode. Move your mouse over the Design 
Mode On/Off icon; see below. If the other icons are enabled as shown then you are in the 
correct mode, design mode; otherwise click the Design Mode On/Off icon to get into design 
mode.

4 Choose View > Toolbars > Form Design. This toolbar lets you control form-level items.
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5 Click both the Display Grid and Snap to Grid icons. The toolbars and grid will look like this.

6 At the top of the document, type Travel  Request  Form  and press Return a few times.
7 Choose View > Nonprinting Characters; you want a checkmark in front of it. This will let you more 

easily see how the form is created.
8 Now you’re ready to start adding fields. On the Form Controls icon, click the Text Field icon.

9 Move your mouse to the indicated area. Click and hold down the mouse, and start drawing a text box 
about an inch and a half in from the left. Draw a text box about two inches long, and release.

10 You’ll also need a label for the field. Click on the Text Label icon.
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11 Draw a label field flush left with the left margin, and about an inch and a quarter wide, as shown.

12 Double-click the Label Field. 
13 In the Properties window, in the General tab, type Name  in the first two fields, then close the window.

14 Double-click the text field.
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15 In the Properties window, type Name Field  in the Name field.

16 Click the browse button in the Label Field field and select the Name text label. This associates the text 
label and its field.

17 Click OK.
18 Close the properties window.
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19 Create another set of text boxes and labels. Make the text box about an inch high, and call the label 
Travel Description.

20 Double-click the Travel Description text box. Type the name Travel Description field and assign the text 
label Travel Description.

21 Select Multi-Line as shown.
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22 In the same window, select Vertical scroll bars. 

23 Close the properties window. The text box should look like this.

24 Create another text label; call it Travel Date.
25 On the Form Controls toolbar click More Controls, then in the More Controls toolbar, click the Date 

Field icon.

26 Draw the date field.
27 Double-click the date field.
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28 From the Data Format field, select Standard (long).

29 In the name field, type Travel  Date F ield  and assign the Travel Date text label.
30 Optional: In the Dropdown list field, select Yes. This will give you a small calendar palette that will help 

users specify dates when the form is in use mode (not edit mode).

31 Close the properties window. 
32 Move the labels closer together vertically.
33 Click the Design Mode On/Off icon.
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34 Enter information in each field to test it. The form should look like this. (If the fields aren’t quite even, 
you’ll align them in the alignment exercise later.)

35 Save the form; you’ll use it in the next lesson.
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Adding Lists, Numeric Fields, and Checkboxes to a Form
1 Be sure the form from the last lesson is open.
2 If necessary, click the Form Design On/Off to get back into edit mode. You’re going to create a list for 

the form from which to choose the travel type. 
3 Create a text label called Travel  Type , below the last label.
4 Click the List Box icon.

5 Draw a normal-sized field. The label and field should look like this.

6 Double-click the list field. In the Properties field, in the List Values field, type the three values shown. 
After you type the first value, press Shift Enter; type the second value then type Shift Enter; type Shift 
Enter and press Enter. 

7 Name the field Travel  Type f ie ld , and assign the text label Travel Type.

8 Close the properties window.
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9 Click the Design Mode On/Off icon.

10 Click the list and select a value.

11 Click the Design Mode On/Off icon.

12 Create a label field below the last label called Reimbursement .
13 Click the Check Box icon. Draw two check boxes as shown.

14 Double-click the first checkbox and in the properties window, type the name Self  Paid . Assign the text 
label Reimbursement. Close the window.

15 Double-click the second checkbox and in the properties window, type the name Company Paid . Assign 
the text label Reimbursement. Close the window.

16 Click the Design Mode On/Off icon.
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17 The form should look like this.

18 Click the Design Mode On/Off icon again to go back into edit mode.
19 Create another text label below the previous label, called Number of  Days .
20 In the More Icons toolbar, click the Numeric Field icon. Draw a field the same size as the others.

21 Double-click the numeric field. Type the name Number of  Days f ie ld .
22 Assign the field the text label Number of Days.
23 Close the properties window.
24 Click the Design Mode On/Off icon.

25 Type a numeric value in the Number of Days field.
26 The form should look like this (grid turned off in this illustration).
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27 Click the Design Mode On/Off icon again to go back to design mode.
28 Save the form.

Creating Radio Buttons
Radio buttons are used for two or more items of which the user can only select one. Examples would be 
whether the event is for beginner or advanced users; on a weekday or a weekend, etc. 

1 Be sure the form from the last lesson is open.
2 If necessary, click the Form Design On/Off to get back into edit mode. You’re going to add another field. 

Employees need to currently be performing acceptably to travel for the company, so you’re going to 
create a set of radio buttons allowing a user to specify only one current status level: below, at, or above 
expectations. 

3 Create a text label called Employee Status , below the last label.
4 Click the Option Button icon.

5 Draw an option button to the right of the Employee Status text box. 

6 Double-click it to open the properties window.
7 Type the name Employee Status Field , and the label Below Expectat ions .

8 Close the properties window.
9 Copy the option button and paste it below the first one, or create another one.
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10 Double-click the second radio button. For this one, be sure that the name is the same (Employee Status 
Field) but that the label is different, Meets Expectat ions .

11 Close the properties window.
12 Create or copy and paste a third radio button.
13 Set the same name (Employee Status Field) but with the label, Exceeds Expectat ions . 
14 Close the properties window.
15 The form should look like this.
16 Click the Design Mode On/Off icon.

17 Select one of the radio buttons, then another. They will alternate; you can’t select more than one at a time. 
This is because they all have the same name, so they work together.

18 The form should look like this (grid turned off in this illustration).

19 Click the Design Mode On/Off icon again to go back to design mode.

Using Group Box Labels
The Group Box is a labeled shape that visually groups radio buttons. You can use it or the standard text label.

1 Be sure the form from the last lesson is open.
2 If necessary, click the Form Design On/Off to get back into edit mode. You’re going to add two more 

radio buttons. Employees need to be able to specify their preference for what type of seat on the airplane, 
so that the in-house travel agency can make the best choices. 
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3 Click the Group Box icon (on the additional icons toolbar).

4 Draw a group box below the previous fields.

5 Double-click the group box. Type the name Seat  Preference  and the label Seat  Preference .
6 Draw two option buttons inside the radio box. Double-click the first one. Specify the name Seat  

Preference Field , label as Aisle , and click the browse icon to specify the label field as Seat 
Preference. 

7 Close the properties window.
8 Assign the same information to the other option button, but type the label Window.
9 Close the properties window.
10 Click the Design Mode On/Off icon.

11 Select one of the radio buttons, then the other. They will alternate; you can’t select more than one at a 
time. This is because they all have the same name, so they work together.
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12 The form should look like this (grid turned off in this illustration).

13 Click the Design Mode On/Off icon again to go back to design mode.

Assigning Tab Stop Order
Users press Tab to go from one field to another. You can control the order in which users get to the fields.

1 Click the Activation Order icon on the Form Design toolbar.

2 The Tab Order window shows the fields and the order in which a user will get to them using Tab. 

3 Use the Move Up or Move Down arrows, or just click AutoSort, to put the fields in order from top to 
bottom of the form. 

4 Click OK.
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5 Click the Design Mode On/Off icon. 

6 Click in the Name field and press Tab to test that the tab order is correct.
7 Click the Design Mode On/Off icon again to go back to design mode. 
8 Save the form.

Specifying Field and Text Label Size
You can rely on the grid to ensure that the fields are similar heights and widths, or you can set it precisely 
yourself.

1 Select the first text label.
2 Right-click on the label and choose Position and Size.
3 In the Position and Size window, type a width and height for the box (not the text within the box). Type 

1.25 as width and .2 as height.

4 Click OK.
5 Repeat for each text label. 
6 Select the first field.
7 Right-click and choose Position and Size.
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8 Type the width 2 and the height .20. (You can choose any height you like; .2 might be too short for some 
fonts.)

9 Click OK.
10 Repeat this for each additional field, except for the scrolling text field which should be an inch high.
Note – A good way to make this a faster process is to apply the height and width when you create 
the first text label, then copy and paste the text label as you need more. You can also do this for fields 
of the same type, like text fields.

Formatting Form Controls
You can specify the font and other attributes of your text fields and labels.

1 Select all the text labels.
2 Right-click on one of them and choose Control.
3 In the Font field, click the browse icon.
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4 Select a different font.
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5 Click the Font Effects tab and, if you want, select a different font color.

6 Click OK.
7 Select all the fields. 
8 Right-click on one of them and choose Control.
9 In the Font field, click the browse icon.
10 Select a different font.
11 Click the Font Effects tab and, if you want, select a different font color.
12 Click OK.
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13 In the Background Color list of the properties window, select a different color.

14 Close the properties window.

Aligning Form Controls
To be sure that the form looks good and prints correctly, align the fields using Alignment and Distribution. 
You can use the visual and snap-to grid, but alignment is another good approach.

1 Select all of the text labels. You can click the Select arrow icon on either form toolbar, then “draw” 
around all the text labels.

2 Right-click on one of the text labels and choose Alignment > Left.

3 Align all the fields at the left, as well.
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4 Select the first text label, and the corresponding field. Right-click on one of them and choose 
Alignment > Top.

5 Align all other text labels and the corresponding fields at the top. (For the checkboxes, just select the text 
label and the first check box.)

6 Now use the arrow keys on your computer to refine the vertical spacing. Select the second text label and 
field, and press the up or down arrow on your computer to space the fields a grid section apart. Vertically 
space the other fields evenly using the same technique.

Creating a PDF Version of the Form
You can also create a PDF version of the form to make available on the web. Users can’t save values in that 
form but they can fill it out and print it.

1 Choose File > Export as PDF.
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2 In the PDF Options window, be sure that Create PDF Form is selected and that the format is PDF. 

3 Click Export.
4 Name the form and click Save; call it formexpor t .pdf .
5 Start Adobe Reader and open the form.
6 The form should look something like this.
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7 Click the + icon at the top to view it larger, then fill it in. You can select the check boxes, the lists, and so 
on. 

You’ll notice that the date does not convert to the long format but stays in standard short format. Also, the 
thousands separator doesn’t appear by default.


