
OpenOffice.org 2 
Resource Kit Sample 
Chapter

Working With Microsoft Office 
and OpenOffice.org

The OpenOffice.org 2 Resource Kit by Solveig Haugland is coming this spring from 
Prentice Hall.

For OpenOffice.org 2 tips and tutorials, visit http://openoffice.blogs.com

Copyright Solveig Haugland 2006





121

chapter

IN THIS CHAPTER

6

Working With 
OpenOffice.org and 
Microsoft Office

• Introduction to Working With Other Office Suites  . . . . . . . . . . . . . . . . . . . . . .page 122
• Solving Compatibility Issues Between OpenOffice.org and Microsoft Office .page 123
• Creating Files Microsoft Office Users Can Read. . . . . . . . . . . . . . . . . . . . . . . .page 127
• Converting Documents to OpenOffice.org Using the Conversion Wizard . . . .page 131



122 Chapter 6  Working With OpenOffice.org and Microsoft Office DRAFT

Introduction to Working With Other 
Office Suites

There will always be people out there using different office suites than you are. They 
aren’t just Microsoft Office users; there are people using WordPerfect, LaTeX, 
various options for Macintosh, and more.  Learning to work with people using other 
office suites will be useful regardless of the office suite you’re using.

I’m going to address working with Microsoft Office in this chapter since that’s mostly 
what you’ll encounter. Additionally, many of the tips will work fine for improving 
compatibility with any other office suite. 

So let’s focus on the key point: you need to work with other office suites, generally 
Microsoft Office. What do you do?

How You’ll Work With Microsoft Office Users 
(Sometimes)
You can open Microsoft Office documents in OpenOffice.org very easily: just choose 
File > Open. (See Opening a Microsoft Document on page 127.) And you can make a 
Microsoft Office version of your OpenOffice.org documents, to send to people who 
just have Microsoft Office. Simply choose File > Save As and choose the right .doc, 
.xls, or .ppt format. (See Saving Your OpenOffice.org Document as a Microsoft 
Document on page 128.)

When you do that, the document often opens up perfectly, or nearly perfectly.

But what do you do if it doesn’t?

How You’ll Solve Formatting Problems 
Between Office Suites
You can solve the formatting problems. See Solving Compatibility Issues Between 
OpenOffice.org and Microsoft Office on page 123.

Or you can avoid the entire problem in the first place by just using PDF when 
you need to send documents to Microsoft Office users. There are never inter-
office-suite formatting problems when you use PDF. See Making Documents 
Everyone Can Read, Using PDF on page 130 and PDF, Publishing, and the Web on 
page 79.
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How You’ll Deal With Your Old Microsoft 
Office Files
You can just choose File > Open and open up any of your old files. But if you need to 
convert a lot of them, use the converter wizard. See Converting Documents to 
OpenOffice.org Using the Conversion Wizard on page 131.

Solving Compatibility Issues Between 
OpenOffice.org and Microsoft Office

Here’s a document in OpenOffice.org Writer, and the same document saved as a .doc 
and opened in Word. The cute red graphical bullets, specific to Writer, were lost. 
Otherwise, it looks pretty good, including the drawing object.

Usually converting between the programs works pretty well. Occasionally you’ll 
encounter problems. The thing is, this isn’t unique to OpenOffice.org. 

w Take a complex document from Word 95 to Word 2003, or vice versa (if 
possible) and you’ll have some interesting differences. 

w If you’re working with Word 2003 on a computer has a big set of fonts, and you 
take a document created on that computer to a computer with Word 2003 but 
fewer fonts, you’ll have formatting differences.

w Take a Word document from one platform to another, and you might encounter 
problems.

Anytime you change the program, program version, or environment (fonts and 
operating system) for a document, there’s a chance things will change. It’s an issue 
with software in general, not OpenOffice.org.
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That said, how do you deal with specific issues between OpenOffice.org and 
Microsoft? That’s what this chapter is all about.

Overall Formatting Solutions
This is the section with all the formatting solutions. I’ve grouped them into 
general guidelines, specific fixes, and setup.

w Fiddle with the margins. Different margins can drastically change how text flows 
on a page. Also fiddle with the font, and font size to make them match the 
Microsoft documents. See Changing Margins on page 169 and Making Text Look 
How You Want It: Basic Formatting on page 132.

w Change the default fonts used for new documents to match the fonts used in the 
Microsoft documents you’re opening. See Setting up Default Fonts for New 
Writer Documents on page 71.

w Change your default template to match the main characteristics of the Microsoft 
documents. See Specifying a Template as the Default Template for File > New > 
Spreadsheet on page 69.

w Change the default tabs slightly; increase them a little or decrease them a little nd 
see what happens. See Setting up Default Tabs on page 155.

w Change hyphenation, text flow, and other items in the Text Flow tab of the 
Paragraph Formatting window. See Reference to Paragraph Formatting Features 
on page 145. (Use this approach only if you’re familiar with these advanced 
features.)

w Sometimes the document you bring from Microsoft Office into OpenOffice.org 
just wasn’t formatted well in the first place. Carriage returns and tabs instead of 
wrapping the text can be one issue.  Show the tabs and carriage returns, and other 
typographical marks. See Viewing Carriage Returns and Other Formatting 
Markups on page 160 to understand these marks. You’ll probably just want to 
delete any tabs or carriage returns in the middle of a paragraph. This will help a 
lot. 

Solving Problems With Specific Pieces of Text 
or Graphics
Occasionally you’ll just have formatting problems with a few pieces of text rather 
than the flow of a whole document. Here’s how to fix those.

w If text formatting is decidedly odd, select the text and choose Format > Default. 



DRAFTSolving Compatibility Issues Between OpenOffice.org and Microsoft Office  125

w If graphics are behaving oddly, right-click on each and choose Anchor > To 
Paragraph. Then reposition the graphic. See Positioning Graphics: Anchoring to 
Paragraph on page 245.

w If this doesn’t do what you want, and you don’t want to have graphics layered on 
top of each other, create a frame. Then cut out the graphics and place them in the 
frame, positioned as you want them. See Frames on page 250. Text boxes and 
graphics that aren’t solidly tied together in Microsoft Office might come flying 
apart in OpenOffice.org, and frames tie them together.

w If bullets are being weird, try graphical bullets instead of font bullets (normal 
bullets).  See Applying Different Types of Bullets on page 125.

Setting Up OpenOffice.org for Better 
Microsoft Compatibility
OpenOffice.org 2.0 has many new settings to help you get great compatibility 
between Microsoft Office and OpenOffice.org. Which ones you use depends on 
how you formatted the original documents, so you’ll need to experiment a bit. 
Here are the items to play with.

Font Replacement

If you’re on Linux and coming from Windows, or just have limited fonts, you can 
substitute all the fonts you don’t have with the best fonts you do have. 

Choose Tools > Options > OpenOffice.org > Fonts. Select a font in the Font list and in 
the Replace list, and click the green checkmark to put it in the list. 
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Compatibility Settings

One of the recent additions is this window. How they each affect your documents 
depends on your setup. However, you should check each and see if it helps with 
conversion. See the online help for more information on each. I particular 
recommend, however, trying the Use Printer Metrics for Document Formatting.

Spreadsheets

This is partly just how spreadsheets behave, but it can help you get more expected 
results.  See the online help for more information on each. 

Choose Tools > Options > OpenOffice.org Calc > General. Select one item to test and 
click OK. Open a Microsoft Office document and see the effect.
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Saving in Microsoft Format All the Time

This might be what you need. See Setting Up OpenOffice.org to Always Save in 
Microsoft Format on page 130.

Creating Files Microsoft Office Users 
Can Read

I’ve talked about solving compatibility issues between the programs. But how do you 
actually take a Microsoft document and open it in OpenOffice.org, so you can have a 
chance at encountering any compatibility problems, period? Or how do you create a 
version of your OpenOffice.org document that can be read in Microsoft Office? 
That’s what I’m covering here.

Opening and Saving Files in Microsoft Office 
Format
This section covers how to open Word documents, how to save OpenOffice.org 
documents in Word or other Microsoft formats, and conversion tips.

Opening a Microsoft Document

1 In OpenOffice.org, choose File > Open. 

2 Locate the Microsoft document on your computer.
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3 Click Open.

4 The document will appear in OpenOffice.org. 

Saving a Microsoft Document as an OpenOffice.org 
Document

If someone sends you a Word document, and you’re just going to keep it, you’ll 
probably want to just save it in OpenOffice.org format. 

1 Open the document in OpenOffice.org and choose File > Save As. 

2 Click on the file type dropdown list. You’ll see several file type options. Select 
the one that makes sense for your document that starts with OpenDocument: 
OpenDocument Text, OpenDocument Spreadsheet, etc.

3 Click Save to save the document. 

Saving Your OpenOffice.org Document as a Microsoft 
Document

When you need to send an OpenOffice.org document to Microsoft Office user, or 
even to a “mixed crowd,” some of who have only Microsoft Office and some of 
whom have OpenOffice.org, you can save your OpenOffice.org document in 
Microsoft format. .

1 Open the OpenOffice.org file. 
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2 Choose File > Save As. You’ll see that you can choose a variety of formats. 

3 Select the format that makes sense for your document that ends with 97/2000/XP: 
Microsoft Word, Microsoft Excel, etc..

4 Click Save.
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Setting Up OpenOffice.org to Always Save in 
Microsoft Format
If you’re always going to need a .doc , .ppt, or .xls version of your documents, you can 
just set up OpenOffice.org to use that format all the time.

Choose Tools > Options > Load/Save > General. In the Default File Format area, 
choose to save Text documents as Word 97/2000/XP documents, and so on. 

When you save documents, you’ll get this message. Click Yes. You can also mark the 
checkbox to not show the message anymore.

Making Documents Everyone Can Read, Using 
PDF
You’re going to work with people who use Microsoft Office, WordPerfect, LaTeX, 
plain old text editors, Lotus, and other programs. There’s no way you want to waste 
time sending them all a document in the format of the program they use.
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Even if you just work with Microsoft Office users, there are disadvantages to sending 
them .doc, .xls, or .ppt files if you don’t have to. They can change the documents, 
which can lead to possible errors. There are potential formatting issues between 
OpenOffice.org and Microsoft Office, just as there are between different versions of 
Microsoft Office. And there’s always the potential to get mixed up and continue 
working on the Microsoft Office version, and then wonder why the changes didn’t get 
into the master copy, the OpenOffice.org version.

You can solve all these problems by sending out your documents in Adobe PDF 
format.

Adobe PDF format:

w Can’t be changed (essentially)

w Can be read by everyone on the planet (virtually) with the free Adobe Reader 
program

It’s a great solution to all the issues I just mentioned.

So use PDF whenever possible. See PDF, Publishing, and the Web on page 79 for 
more information.

Converting Documents to 
OpenOffice.org Using the Conversion 
Wizard

You’ve switched to OpenOffice.org. You’re happy, you’re ready to go. And then you 
realize you have a couple thousand Microsoft Office format documents and templates. 
Now, this isn’t a huge deal because any time you open a Microsoft Office document 
in OpenOffice.org, it just works. You can then save the document or template in 
Microsoft or OpenOffice.org format. 

However, it does take a bit of time for each document. Wouldn’t it be great if there 
were a way to do it all at once?

Useful Things You Can Do With the 
Conversion Wizard
Of course, there is a way to do it all at once. Here are a few applications for the 
wizard.
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w Convert Microsoft Office documents to OpenOffice.org documents – You can 
use the conversion wizard to make OpenOffice.org copies of all your Microsoft 
Office documents. (That’s copies—it doesn’t change the actual original 
documents.) 

w Convert Microsoft Office templates to OpenOffice.org templates – A particularly 
nice use for the converter is converting Microsoft format templates to 
OpenOffice.org format. Microsoft does make nice templates, and if you own’em, 
there’s no reason you can’t just use them with OpenOffice.org. Just slam the 
templates through the wizard using the steps in this section. Then you’re ready to 
follow the directions in Using Existing Writer, Calc, and Impress Templates in 
OpenOffice.org on page 61.

w Convert older OpenOffice.org documents and templates to the latest version – 
That pretty much says it. You can also use the wizard to convert your 
OpenOffice.org 1.x documents to 2.0 format.

Using the Conversion Wizard
1 Create a directory for the copies that you will create with the converter: for all the 

documents or for each separate directory. You might do this, for instance.

2 Choose File > Wizards > Document Converter.

Your current files, in 
Microsoft Office or 
OpenOffice.org 1.x format.

A new set of empty directories 
where you’ll have the conversion 
wizard create new 
OpenOffice.org 2.0 copies.
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3 What you select depends on what you need to do.

w If you’re converting from Microsoft Office, select Microsoft Office  and all 
types of documents you want to convert. 

w If you’re converting from OpenOffice.org 1.x, select StarOffice and all the 
types of documents you want to convert.

4 Click Next. In this window, specify where you want to convert from, and where 
you want the copies to go, for each type of document. Once you set it up in one 
set of fields you can copy and paste the paths to the other fields. You want to 
specify the smallest directory you have set up; note that the example shows the 
\reports\annualreports directories, not just the \reports directories.

5 Click Next and fill in the information it asks you for.

6 In the Summary window, review the information, then click Convert. 

7 A progress message will show what’s happening. When the conversion is done, 
you’ll have converted copies in the target directories.


