Simple Data Sources and Mail
Merges for OpenOffice.org 1.x
What’s a data source? Data sources are how you get OpenOffice.org to recognize that you’ve got

information in a database, spreadsheet, text file, or other form that you want to use in OpenOffice.org
documents.
What’s a mail merge? This means you can do things like make a bunch of labels or letters, one for

each person in your address book, or you can print a copy of the same letter for every person in the
spreadsheet where you keep your customer list.

Firstname
John
Mary
Ellen

Lastname
Hanson
Jones
Meringue

Address
City
910 Harris Dr Kalispell
11 Main Street Bozeman
1788 W 105th Boulder

State
MT
MT
CO

ZIP
59901
57788
80302

Dear John,

Dear Mary,

Dear Ellen,

Thanks for your order this
year. Be sure to let us know
if we can do anything in the
coming year!

Thanks for your order this
year. Be sure to let us know
if we can do anything in the
coming year!

Thanks for your order this
year. Be sure to let us know
if we can do anything in the
coming year!

Dan Axtman
Working Knowledge Books

Dan Axtman
Working Knowledge Books

Dan Axtman
Working Knowledge Books

If you want to use data sources and put them in documents, you need three things.
1

Data, such as a spreadsheet, text file, or a database like Oracle

2

A data source configuration in OpenOffice.org, pointing to the data.

3

A document like a mail merge letter or envelope document for Writer, or for Calc, you might use
the Data Pilot.

Exercises
1. Creating Data
Usually you’ll have the data already; you might have a spreadsheet or text file of names and addresses
on your computer. However, here’s an example of how to do it.
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Creating a Text File for a Data Source
1

Start Notepad or a similar simple text editor and create a new file.

2

Type the following, with a tab between each unit of data.
First Name
Martin
Marilyn
John

3

Last Name Address
Rogers
101 Main St
Lundsverk 99 Grand Avenue
Barton
110 Ludlow

City
St Paul
St Paul
Fargo

State
MN
MN
ND

Postal Code
56546
56549
57799

Save the text file as mysimpletext.txt or another easily recognizable file name.

Creating a Spreadsheet for a Data Source

You’re going to do the same thing you did with the text file, but in a spreadsheet. You can copy and paste the data
if you want, or retype it.
1

Create a new empty Calc spreadsheet.

2

Type the following, each piece of data in a separate cell.
First Name
Martin
Marilyn
John

3

Last Name Address
Rogers
101 Main St
Lundsverk 99 Grand Avenue
Barton
110 Ludlow

City
St Paul
St Paul
Fargo

State
MN
MN
ND

Postal Code
56546
56549
57799

Save the spreadsheet as mydataspreadsheet.sxc or another easily recognizable file name.

2. Creating Data Sources
Once you’ve got data like the text file in the previous exercise, or a spreadsheet like the one stored in your lab
files, it’s time to create the data source in OpenOffice.org that points to that data.
Creating a Simple Data Source From a Spreadsheet

You’ve got a spreadsheet full of the names of people who’ve expressed interest in learning about writing for
Working Knowledge’s new in-house publishing business. You need to have this information in a data source for
the whole department to use.
1

Locate spreadsheetM in the mailmerge directory of your lab files; don’t open it.

2

Copy it to a new directory, such as datasources .
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3

Choose Tools > Data Sources.

4

Click New Data Source.

5

Type a name for the data source, potential_authors .

6

In the Database Type dropdown list of the window, select Spreadsheet as the type.
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7

In the Database URL field, click the browse icon and specify spreadsheetM in its new directory.

8

Click OK to close the window and save your new data source.

Creating a Simple Data Source From a Text File
1

Start an OpenOffice.org Writer document if it’s not already open.

2

Choose Tools > Data Sources. The Data Source Administration window will appear.

3

Click New Data Source.
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4

Name the data source simple_text .

5

Select Text in the Database Type dropdown list.
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6

Use the browse icon in the Database URL field to specify the directory where the text file you created is.

7

Click the Text tab.

8

Select Tab as the field separator.

9

Click OK to close the window and save changes.

10 Choose View > Data Sources.
11 Click the + symbol by the simple_text data source, then click the + by Tables. It should look something like
this.
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The data source is ready for use with mail merge autopilots, labels, the Data Pilot, and other tasks.

3. Creating Mail Merge Documents
You’ve got data, and you’ve defined a data source. Now you just need to put all that data in a document like
labels, a mail merge letter, or envelopes.
Creating a Mail Merge Letter Using the Letter AutoPilot
1

Choose File > AutoPilots > Letter.

2

Accept the defaults in the first window and click Next, then click Next in the second and third windows too.

3

Click Next.

4

When you reach the fourth window, select your new potential authors data source in the first dropdown list.

5

Select the Sheet1 table listed in the second dropdown list.

6

Select the first name, last name, address, city, state, and postal code fields and click the arrow to move them
from the Database Fields list into the Address Fields list. Type a space after each field you insert, since the
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fields aren’t automatically spaced apart, and click the new line arrow button after the last name and address
fields.

7

In the dropdown lists at the bottom, keep Dear as the salutation and Firstname as the other field.

8

Click Create. The new mail merge document will appear.

Copyright GetOpenOffice.org

9
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Save it in your lab files directory, with the title my_lettertoauthors .

10 Type some brief text in the new document, telling the recipients they are invited to a presentation at 10 AM
this coming Saturday.
Creating Mail Merge Envelopes

You’ll need to have addressed envelopes for each of these letters, as well. You can do this by printing labels, or by
printing on the envelopes directly.
To print envelopes, you’ll create a new Writer document, and set it up to print a specific type of envelope. It must
exactly match the kind of envelopes your own printer can create.
1

Create a new Writer document.

2

Choose Insert > Envelope.

3

Click on the Envelope tab if it’s not already showing.

4

Select Potential Authors from the datasources dropdown list and Sheet1 from the Table list.

5

In the Database Field list, select the first field to insert, such as name, and click the bold arrow next to it to
insert the field in the Addressee area. Type a space after the newly inserted field.

6

Insert all additional name, address, city, state, and postal code information, inserting spaces between fields
and moving to a new line as appropriate.
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7

Click the Sender checkbox. Type or paste the sender name and address in the Sender field.

8

Click New Doc to create the envelope document.
Note – If you have any problems printing, click the Printer tab when you perform this procedure. Note where
the envelope will print in the paper tray, so that you can insert envelopes correctly during printing. Additionally, in the Format tab, make sure that the envelope type listed there is the same one your printer is set up to
print. Envelope 10 is a common envelope type.

Creating Mail Merge Address Labels
1

Choose File > New > Labels.

2

In the Labels tab of the Labels window, select the data source you created, such as Potential Authors, from the
Database dropdown list.

3

Select a table, such as Sheet1, from the Table list.
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4

Select the first field you want to use from the Database Field list, and click the arrow next to it to insert it in
the text field. Type a space after the field.

5

Use the Database Field list to insert the appropriate address fields, spaced appropriately and on the correct
lines.

6

In the Brand dropdown list, select Avery Letter Size.

7

In the Type dropdown list, scroll through the billions of labels. Select 8160 Inkjet Address.

8

Click New Document. The labels will appear.
Note – Using the Synchronize feature here isn’t useful since it just puts the same data in every single field. If
you want to do formatting, use styles and just apply each style to each frame.
Note – If you have any problems printing, check your printer setup using your operating system setup tools.

Creating a Mail Merge Document From Scratch
1

Create a new Writer document.

2

Choose View > Data Sources.
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3

Select the Potential Authors data source and expand to see the table.

4

In the document, choose Insert > Fields > Date to insert the date field.

5

Type Dear , then drag the First Name field into the document.

6

Type the rest of the document as shown, dragging also the User1 field into the document at the appropriate
spot.

7

Save the document.

Printing Mail Merge Documents
Printing is nearly the same as a normal document; you just get an extra window where you can select which data
source to use, and which records to print.
Printing a Mail Merge Letter

You’re ready to print the letter that you created in a previous lesson.
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1

Open the lettertoauthors.sxw document if it’s not already open.

2

Choose File > Print.

3

You’ll be asked whether you want to print a form letter. Click Yes.

4

In the printing window, select only the first three records. You’ll print all the letters to all recipients later when
you’re sure the letter looks the way you want.

5

Be sure that the printing destination is Printer.

6

Click Print.

7

The standard printing window will appear. This is where you specify standard printing information such as
number of copies and the pages to print. Then click OK to print the letters.

Printing Mail Merge Envelopes
1

If you created a mail merge envelope before, open it or switch to it.

2

Choose File > Print.
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3

You’ll be asked whether you want to print a form letter. Click Yes.

4

In the Form Letter window, specify that you want to print the first three records.

5

Be sure Printer is selected.

6

Click OK.

7

Specify the printer to print to and click OK.

8

Feed envelopes into the printer.

Printing Labels
1

If you created a mail merge envelope before, open it or switch to it.

2

Choose File > Print.

3

You’ll be asked whether you want to print a form letter. Click Yes.

4

In the Form Letter window, specify that you want to print the first three records.

5

Click OK.

6

Specify the printer to print to and click OK.
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Previewing the Data That Will Print in Mail Merge Documents
When you create a
document, you see
something like this:
the references to the
data source rather
than the data itself.
This is fine; the
documents will print
with the right data.
However, if you want
to preview what the
document looks like
with data instead, follow these steps.
1

Be sure your mail merge document, such as labels or a letter, is open.

2

View data sources by choosing View > Data Sources. The data sources you have created will be displayed.

3

Find the data source you’re using and click the + sign by it to expand it. Click the + sign by the Table heading
under that data source, then select the table you’re using.
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4

The data you’re using will appear. Click the indicated box in the data area.

5

Click the indicated icon, Field to Data, to show data instead of field references. If the data still isn’t displayed,
choose View > Fields.

