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Welcome to the 
GetOpenOffice.org 

Workbook Series for 
StarOffice 8.0 and 
OpenOffice.org 2.0

Get started by ensuring you have the files to do the exercises. You can 
download the Core Office Suite lab files from www.getopenoff ice.org/ labf i les.

To read a little about OpenOffice.org or StarOffice, see About 
OpenOffice.org and StarOffice on page ix.

Then just start the exercises on page 1. 

We hope you enjoy and learn from your GetOpenOffice.org workbook. 
Please contact us at t ra ining@getopenoff ice.org if you have any questions, 
comments, or inquiries about other training or training products.





page v

Table of Contents: Essentials

Starting and Running OpenOffice.org  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1
Starting OpenOffice.org  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1
Creating Another OpenOffice.org File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3

OpenOffice.org and Other Office Suites. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Opening a Microsoft Text Document  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Opening a Microsoft Spreadsheet . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Saving a Microsoft Text Document as an OpenOffice.org Text Document  . . . . . . . . . . . . . . . . 5
Saving a Microsoft Spreadsheet as an OpenOffice.org Spreadsheet . . . . . . . . . . . . . . . . . . . . . 6
Saving an OpenOffice.org Document as a Microsoft Document  . . . . . . . . . . . . . . . . . . . . . . . . 7
Using the Document Converter  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
Fixing Formatting Problems Between Applications . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

Getting to Know OpenOffice.org: Tooltips and Help  . . . . . . . . . . . . . . . . . . . . . . . . 10
Figuring Out What Icons Do  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
Using the Help  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

Setting the Unit of Measure . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Setting up the Ruler’s Unit of Measure in Writer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Specifying Unit of Measure for Formatting Windows in Writer  . . . . . . . . . . . . . . . . . . . . . . . 12

Turning Off Automatic Formatting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
Turning Off Word Completion in Writer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
Turning Off Other Automatic Formatting  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
Creating a Shortcut in the Automatic Formatting Window  . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

Setting Up OpenOffice.org: Icons and Toolbars . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
Making Icons Easier to See  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
Seeing All the Icons on a Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
Viewing the OpenOffice.org Toolbars  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
Docking and Other Ways of Displaying and Positioning Toolbars . . . . . . . . . . . . . . . . . . . . . 22
Showing More Icons on Your Toolbars  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
Creating Your Own Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

Tips for Using and Finding Features  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
Right-clicking  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
Using the Icons With Black Triangles  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30





page 1

Starting and Running 
OpenOffice.org

This section covers how to start the program, and open and save files.

Starting OpenOffice.org

1 Open a new Writer document by choosing Start > Programs > OpenOffice.org > Text Document or 
as directed by your instructor. (If you’d rather open a spreadsheet, choose OpenOffice.org 
Spreadsheet instead.)

2 A new empty document will appear.

3 Type a few words in the document.
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4 Save the document by choosing File > Save.

5 In the Save window, find the directory where you want to save the document. The directory where your 
training lab files are located is fine, create your own directory, or just save in My Documents. 

6 Save the file as mynewdocument, or as directed by your instructor.

7 Click Save. Keep the program open and keep your new document open.
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Creating Another OpenOffice.org File

Once you’ve got a document open, you can create any kind of other document from within the program instead of 
using the Start button or another external approach. 

1 In OpenOffice.org, choose File > New > Text Document to create a Writer document.

Tip: You can also click on the New icon and choose Text Document to create a new document.

2 Choose File > New > Spreadsheet to create a new spreadsheet.

3 Choose File > New > Drawing to create a new drawing.

4 Close the new drawing without saving.

5 Close the new spreadsheet without saving.
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OpenOffice.org and Other Office 
Suites

This section covers how to open other documents such as Microsoft Word documents, how to save 
OpenOffice.org documents in Word or other Microsoft formats, and conversion tips.

Opening a Microsoft Text Document

1 Be sure you’re in an OpenOffice.org document. It can be any Writer document or any other kind.

2 Choose File > Open. (You can’t typically open a Word document in OpenOffice.org by double-clicking it 
unless you set up your operating system to do so.)

3 Locate the word1.doc document in the Essentials folder of your lab files.

4 Click Open.

5 The document will appear in OpenOffice.org. 

Opening a Microsoft Spreadsheet

1 Be sure you’re in an OpenOffice.org document. It can be any Calc document or any other kind.

2 Choose File > Open. (You can’t open an Excel document in OpenOffice.org by double-clicking it unless you 
set up your operating system to do so.)
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3 Locate the labfiles\essentials\excel1.xls document.

4 Click Open.

5 The document will appear in OpenOffice.org. 

Saving a Microsoft Text Document as an OpenOffice.org Text 
Document

If someone sends you a Word document, and you’re gong to keep it and work on it for a while, it’s a good idea to 
save it in OpenOffice.org format. You’ve just been given this excel1 spreadsheet and told to take a look at it, 
check the information, etc.

1 Open the word1.doc document in your Essentials lab file folder if it’s not already open. 

2 Choose File > Save As. 

3 Click on the file type dropdown list You’ll see several file type options.
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4 Select the top option in the window, OpenDocument Text. 

5 Click Save to save the document. (Make sure it’s somewhere you can find it again.)

Saving a Microsoft Spreadsheet as an OpenOffice.org Spreadsheet

1 Open the excel1.xls document in the Essentials folder of your lab files if it’s not already open. 

2 Choose File > Save As. 

3 Click in the file type dropdown list You’ll see a few different options.

4 Select the top option in the window, OpenDocument Spreadsheet. (You might have to scroll up to see it.) 

5 Click Save to save the document. (Make sure you’re in the My Documents directory or somewhere you can 
find it again.)
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Saving an OpenOffice.org Document as a Microsoft Document

When you need to send an OpenOffice.org document to a “mixed crowd,” some of who have only Microsoft 
Office and some of whom have OpenOffice.org, you’ll need to save your OpenOffice.org document in Microsoft 
format. Your boss at Working Knowledge needs you to do this with a couple documents she’ll be sending to the 
board of directors.

1 Open the OpenOffice.org file, spreadsheet1 in the Essentials folder of your lab files. 

2 Choose File > Save As. You’ll see that you can choose a variety of formats. 

3 Select the Microsoft Excel 97/2000/XP format.

4 Click Save.

5 Note: If you were saving a Writer document as Word, you would choose Microsoft Word 97/200/XP.
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Using the Document Converter

You can quickly create new, current-version OpenOffice.org copies of Microsoft Office documents using the 
document converter.

1 Set up directories for the new 2.0 copies. For every directory of old documents, you want another, like 
monthlyreports and monthlyreports20.

2 Be sure OpenOffice.org is running. If it isn’t, choose Start > Programs > OpenOffice.org 2.0 > 
OpenOffice.org Writer.

3 Choose File > Wizards > Document Converter.

4 Select Microsoft Office and all types of documents you want to convert. 

5 Click Next.

6 Specify the directory of the old documents, and the new directory that you created. For instance, you’d 
specify C:\:reports\monthlyreports in the first field for each type of document, and 
C:\:reports\monthlyreports20  in the second field, for each type of document.

7 Follow the wizard through and convert the documents. You’ll get copies of the original documents; the 
originals aren’t affected.
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Fixing Formatting Problems Between Applications

• If formatting changes aren’t being saved, go under Tools > Options > Load/Save > General. At the bottom of 
the page, you might see that text documents are set up to always save as Word files, or 1.x OpenOffice.org 
files. Change the settings so that text documents always save as Writer files, spreadsheets always save as Calc 
files, and so on.

• Check the page formatting. Choose Format > Page and adjust the page size, margins, and page orientation.

• If text formatting is decidedly odd, select and choose Format > Default to remove formatting and start over. 

• Change the font and/or font size. Select the text and choose a different font and font size from the dropdown 
lists at the top left of the toolbar.

• If graphics are behaving oddly, right-click on each and choose Anchor > To Page. Then reposition the 
graphic. You might also want to slightly shrink the graphic so it will fit better, or increase the size.

• For lists, select the list and click the numbering or list icon to turn off all numbering or bullets. Then reapply 
the list or bullets by clicking the same icon again.

• Adjust the default tabs. Choose Tools > Options > OpenOffice.org Writer > General. Set the tabs slightly 
smaller or slightly larger and check the effect.

• Adjust the default fonts. Choose Tools > Options > OpenOffice.org Writer > Basic Fonts (Western). Specify 
the fonts and font sizes that fit best in your documents.

• Check the fonts that are used with your printer and operating system. You might want to set up  font 
substitution. Choose Tools > Options > General > Fonts, and use the online help to apply the replacement 
table. Replace fonts you can’t use with fonts you can.

• Choose Tools > Options > OpenOffice.org Writer > Compatibility. If the printer metrics option at the top isn’t 
on, select it. Try changing the other settings in the window and see if those items help.
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Getting to Know OpenOffice.org: 
Tooltips and Help

Figuring Out What Icons Do

Some of the icons like B I and U are self explanatory; some are harder to figure out. The tooltips are an excellent 
way to find your way around OpenOffice.org.

1 Be sure OpenOffice.org is running with a document open. If it isn’t running, choose Start > Programs > 
OpenOffice.org 2.0 > OpenOffice.org Writer.

2 Move your mouse over any of the icons in the work area and hold it 
there. You’ll see a small tip describing what the icon does.

Using the Help

The online help is, well, helpful, to figure out new topics.

1 In any OpenOffice.org document, press F1 or choose Help > OpenOffice.org Help. The main help window 
will appear.

2 Click the Find tab.
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3 Let’s say you want to find out how to make text colored. Type colors in the find field.

4 In the results that appear, you can see one of the items is fonts. Double-click that one. 

5 You’ll see help on the topic of colors and fonts.

6 Now create a new Writer document or use one that you have open. Type some text, and change the color using 
any of the instructions in the Help file.
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Setting the Unit of Measure

Setting up the Ruler’s Unit of Measure in Writer

1 Be sure OpenOffice.org is running with a document open. If it isn’t, choose Start > Programs > 
OpenOffice.org 2.0 > OpenOffice.org Writer.

2 Be sure the ruler is displayed. If it isn’t, choose View > Ruler.

3 Right-click on the ruler and choose what you want. 

Specifying Unit of Measure for Formatting Windows in Writer

You already specified the unit of measure for the ruler shown in your files. That unit of measure is independent 
from that. You’ll see it in windows like the one shown at right when you do advanced tasks later on with 
OpenOffice.org. (To get to the window shown, choose Format > Paragraph.)
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1 Choose Tools > Options > OpenOffice.org Writer  > General. 

2 Specify the unit of measure you want for formatting windows.

3 Click OK.
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Turning Off Automatic Formatting

Turning Off Word Completion in Writer

You’ve probably noticed the automatic word completion and other “help” the program gives you. It’s best to turn 
all of that off, then turn on only the things you want and need. 

1 Be sure OpenOffice.org is running with a document open. 

2 Choose Tools > AutoCorrect.

3 The window will look like this. If the Word Completion tab isn’t in front, click on it.

4 Unmark the Enable Word Completion option.

5 Click OK to save the changes.

Turning Off Other Automatic Formatting

1 Be sure OpenOffice.org is running with a document open. 

2 Choose Tools > AutoCorrect.

3 Click the Options tab of the AutoCorrect window. 
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4 Unmark everything in both columns except the top two items. (This window will look different depending 
on whether you’re using Writer, Calc, or Impress or Draw.) 

5 When you’re done, take a look at the options and see if there’s anything that you think would be useful. Ask 
your instructor about options you need to know more about. Mark both checkboxes next to anything you 
want.
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Creating a Shortcut in the Automatic Formatting Window

Let’s say that you type a certain word or phrase several times daily. It might be your name, it might be a technical 
term, or some word that’s just annoying or labor-intensive to type. You can set up a shortcut to enter the phrase 
automatically.

1 Be sure OpenOffice.org is running with a document open. 

2 Choose Tools > AutoCorrect.

3 Click the Replace tab.

4 In the Replace field, type the shortcut for your word, and in the right-hand With field, type the actual word 
you want to appear in the document. For your name, for instance, you’d type your initials in the Replace field 
and your name in the With field. 
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5 Click New. The shortcut and phrase will appear.

6 Before leaving the window, click the Options tab. Be sure that the top two checkboxes are marked. These 
checkboxes mean “Use everything in the Replace tab.”

7 Click OK.

8 In a blank Writer document, type the shortcut you specified, followed by a space.

9 The replacement phrase you specified will appear.
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Troubleshooting

If you have problems with this or other 
automatic formatting, check the language 
dropdown list in the AutoCorrect window. 

Be sure that it matches the language chosen in the Tools > Options > Language Settings > Language, and in the 
language in the Character Format window.  



Copyright GetOpenOffice.org Making Icons Easier to See  |  page 19  

Setting Up OpenOffice.org: Icons and 
Toolbars

This section covers setup tips that customize OpenOffice.org and make it easier to use.

Making Icons Easier to See

In any program, there are a few tricks that make life a lot easier. Here are the main ones for OpenOffice.org. Do all 
of these steps on any computer where you use OpenOffice.org.

1 Be sure OpenOffice.org is running. If it isn’t, choose Start > Programs > OpenOffice.org 2.0 > 
OpenOffice.org Writer.

2 Choose Tools > Options.

3 Under the OpenOffice.org category, find View. In the window shown, change the Scale to something like 
125%. This affects the display size of the content of a document; the stuff you put into it like text and 
graphics.

4 Select the Large  item from the Icon Size list. 

5 Click OK to save your changes and close the window.

Seeing All the Icons on a Toolbar

If you increase icon size or shrink your window, you won’t see all the icons at once. Your icon for changing text 
color, for instance, might disappear. Here’s how to see the indicators that some icons are hidden, and how to get to 
them.

1 If you don’t have a Writer document open, open one you’ve already worked with, or choose File > New > 
Text Document to create a new document.

2 Shrink the window to about half its usual size. 
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3 Find the set of arrows at the right side of the toolbar.

4 Click the horizontal double arrowhead. You’ll see the names of all the icons that there isn’t currently room to 
display on that toolbar.

5 Select the function you want. 

Note: You’d normally want to select the text you want to apply the function to first; for instance, if 
you want to indent text, you’d select that text, then click on the double arrow, then select the 
function you want.

Viewing the OpenOffice.org Toolbars

OpenOffice.org shows you the basic toolbars when you open a new document. Here’s how to show or hide any of 
the many others.

1 If you don’t have a document open, choose File > New  to create one.
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2 Choose View > Toolbars. There are a lot of choices, including some pretty specialized ones. The ones you see 
will depend on what type of document you have open. 

3 Select Bullets and Numbering. That’s the specialized list toolbar. Use this anytime you want to do 
complicated indented lists.

4 Click the X in the upper right corner to close it. If there isn’t an X, choose View  > Toolbars > Drawing again 
to hide the toolbar.

5 Choose View > Toolbars > Drawing. The Drawing toolbar will appear, probably at the bottom of the work 
area. 

6 Choose View > Toolbars > Drawing again to hide the toolbar.
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Docking and Other Ways of Displaying and Positioning Toolbars

The 2.0 OpenOffice.org interface lets you drag around the toolbars to wherever you want. 

Here are some general guidelines to review before beginning the exercises.

• Showing – If you want a toolbar to show, just choose View > 
Toolbars > name and it’ll show. (There needs to be a checkmark by 
the toolbar for it to be displayed.) 

If it’s floating and showing, just click the X to make it go away.

• Floating or docked – The toolbar appears floating or docked on the toolbar. Docked just means it looks like 
a normal toolbar and it’s next to the other toolbars

Docking a floating toolbar

1 Drag it to where you want it near the other docked toolbars. 

2 A dashed outline of the toolbar will show where it’ll end up.

3 Release your mouse.

Making a docked toolbar float

1 Locate the vertical dashed line at the left side of the toolbar.  

2 Drag it to the work area.

Floating

Docked
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3 A dashed outline of the toolbar will show where it’ll end up.

4 Release your mouse.

Repositioning a docked toolbar 

You can move the toolbar from right to left as you like. 

1 Locate the vertical dashed line at the left side of the toolbar.  

2 Drag the toolbar where you want it to be.

3 Release your mouse.

Showing More Icons on Your Toolbars

The OpenOffice.org developers put what they think are the most commonly used icons on the toolbars, but those 
aren’t the only ones available. You can add others that you like better, and remove the ones there already.

1 Be sure OpenOffice.org is running with a document open. If it isn’t, choose Start > Programs > 
OpenOffice.org 2.0 > OpenOffice.org Writer.
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2 Click on the downward-facing arrow on the formatting toolbar and choose Visible Buttons. 

3 A list of all the icons available to put on that toolbar will appear. To add an item, find one without a check 
mark next to it and select it.

4 To delete an item, find an item with a check mark next to it and select it.

Creating Your Own Toolbar

There are many features that are not shown on the default toolbars, or that are hard to get to as icons. It’s very 
helpful to create your own toolbar with a grouping of icons you use frequently. You can use icons from other 
toolbars, or icons that aren’t shown. 

In this example, you’re going to create a toolbar for Calc with several printing-related icons. You can also use 
the principles in this procedure to simply add an icon to an existing toolbar.

1 Start OpenOffice.org if it’s not already running and create a new spreadsheet. (Choose File > New > 
Spreadsheet.)

2 Click on the downward-facing black arrow at the far right side of the work area and choose Customize 
Toolbar.
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3 In the window that appears, you can see all the existing toolbars. You could modify an existing one, but for 
now you’re going to create a new one. Click New.

Note: If you want to add an icon to an existing toolbar, just select it from the Toolbar list and click 
Add, rather than creating the new toolbar.

4 In the window that appears, type the name Printing and click OK.

5 The Printing toolbar will appear, with no icons in the list.
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6 Click Add. In the window that appears, you can select any icons you want to add to the new toolbar. It’s a bit 
annoying to scroll through all the categories, so when you’re looking for something in the future, expect to 
take some time. For now, however, we’ll tell you which icons and categories to look for. 

Select the Documents category.

7 You want to add the Export as PDF, Export Directly as PDF, Print, Print File Directly, Printer Settings icons 
(and anything else you think would be useful). Select the first and click Add, then click the next one, and so 
on.
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8 Now select the View category and find the Page Preview icon. Click Add.

9 Now select the Format category. You’re looking for several icons which aren’t together; I’ve shown them 
together here. 

Scroll through the list and as you find each, click Add.
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10 Now click OK. The toolbar is shown in the main definition window.

11 Click OK. The toolbar should be displayed.

12 If it isn’t displayed, choose View > Toolbars > Printing.
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Tips for Using and Finding Features

This section teaches how to learn the GUI tools you might not have used in other applications, or might not have 
used as much.

Right-clicking

Right-clicking on an item will show you most of the things you can do with an item. When in doubt, right-click.

1 Be sure OpenOffice.org is running with a document open. If it isn’t, choose Start > Programs > 
OpenOffice.org 2.0 > OpenOffice.org Writer. (The usefulness of the right-click applies across 
OpenOffice.org to all types of documents.)

2 Type a few words in the document.

3 Select the text.

4 Right-click on the text. You’ll see a menu like this one.

5 Select any of the options, such as Line Spacing. If you get another option, select one of those.

6 See the effect on the text.

7 Open the writer3 document, in the Essentials folder of your lab files.

8 Select the top graphic.

9 Right click on it. Select any of the options you see.
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Using the Icons With Black Triangles

Usually when you click on an icon, a window comes up or something happens. In OpenOffice.org, some of the 
icons across the top in the toolbars, and the icons in the toolbar with a black triangle, give you more options. 

Click and hold down the mouse on 
any toolbar icon with a black triangle.

A palette of icons will appear. You can 
either click on one of the icons.

Or click on the border at the top of the 
menu. Drag the palette a little to one 
side, or up or down.

Sometimes the icon will look like 
this when you click on it; there 
won’t be a solid border, just a 
couple lines.

But you can still just click on one of 
the icons, or drag the double lines 
up a bit and the palette will stay, just 
like the other palettes.

The palette will separate and stay 
displayed. Then you can click on the 
palette items and the palette won’t 
disappear.
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1 Create a new text document.

2 Choose View > Toolbars > Drawing and the Drawing toolbar will appear at the bottom of the work area.

3 Click and hold down the mouse on the Basic Shapes icon.

4 When the palette of options appears, click and hold down on the double lines on top.

5 Drag the palette to one side.
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6 Click on the Isosceles Triangle tool.

7 Draw a triangle in the document.

8 Above or below the rectangle, type the text Using the Icons With Extra Opt ions .

9 Locate the Font Color icon on the formatting toolbar, and click on it

10 Click on the border at the top and drag the menu bar slightly either left or right.
 

Drag the Font Color title bar Release the title bar
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11 Now that the color palette is ready, select the text you typed previously (do this before you apply color).

12 Find a color you like in the palette of colors and click on it to apply the color to the selected text.




