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Using Tables
Sometimes you just need a document with standard text and pictures, one after another. You have a 
paragraph, a list, a picture, and so on.

That ends pretty quickly when you get anything remotely complicated, or if you need to cram a lot 
of information onto a page. It’s also time for a new approach if you want to be able to easily 
compare information side by side. 
Anytime you want to control visually where pieces of text go, when you’ve got lots of data to 
present in one spot, or if want to be able to do a little math with your numeric data, tables are a 
great idea. It’s also a good idea to use tables when you have two columns of information that need 
to be side by side, and there are two or more rows in the first column.

Creating Writer Tables
Tables are pretty easy to insert and fiddle with. Use the Table menu, and all the features are right 
there. You get a special formatting bar for the table that has pretty much everything you need, and a 
toolbar that pops up to give other ways to access the features.

Tables are good for 
straight-up financial 
figures, since you can 
easily compare the data, 
and you can apply 
automatic currency 
formatting.

Tables let you arrange 
different pieces of 
information for particular 
topics, as shown. In this 
and the above example, 
you also see some options 
for shading and border 
formatting.

Tables are an excellent 
approach for information 
like the example at left. 
Just use a table, and take 
off the borders. You will 
drive yourself crazy if you 
try to do this with tabs or 
wrapping text.
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Inserting a Table 
There are a couple approaches to inserting a table.

Creating a Table Using the Table Menu
1 Choose Insert > Table.
2 In the Insert Table window, specify the number of columns and rows. (This includes the 

header row.) If you don’t want a header, unmark it.

3 If you want to apply an Autoformat, click the Autoformat button and make your selection. 
(For more information, see Creating and Applying AutoFormats: The Table Formatting 
Timesaver on page 193.)

4 Click OK.
5 The table will appear in the document.
6 Fill in the table as needed. You can press Tab to move from cell to cell (Shift + Tab to move 

back). 

Creating a Table Using the Insert Menu or the Insert 
Table Icon
You can also insert a table by choosing Insert > Table. Another option is to 
display the Insert toolbar. Click and hold down on the Insert Table icon and 
select the number of rows and columns.
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Creating a Table With Multiple or No Heading Rows
1 Choose Insert > Table.
2 In the Insert Table window, select or unmark the Heading option.

3 To have multiple heading rows, specify the number of heading rows; these rows will repeat on 
each page.

4 Specify the number of standard rows and other options, as usual.
5 Click OK. 

Table Management Tips
Some aspects of tables are a bit tricky; here’s how to do the basics.

Inserting a Blank Line at the Top of a Page Above a Table
You’ve inserted a table at the top of a page, and now you want regular text above the table. To do 
this, click in the top left cell of the table, and press Return.

Separating Two Tables
You’ve got two tables, one immediately on top of the other. You want regular text between them; 
what do you do?
It’s the same as inserting a blank line above a table. Click in the top left cell of the second table, 
and press Return.

Deleting Just the Contents of a Table
Select the table and press Delete. Only the content will disappear.
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Deleting a Table
Here’s one approach.
1 Select the first line above the table, as well as the entire table.

2 Press the Delete key on your keyboard. The table disappears.
Another approach is to select the whole 
table and click either the Delete Row or 
Delete Column icon.

Deleting Rows or Columns
Click in the row(s) or column(s) you 
want to delete. Then use the Delete Row or Delete Column icons shown previously, or right-click 
and choose Row > Delete or Column > Delete. And in yet another approach, you can choose 
Table > Delete > Rows or Table > Delete > Columns.

Skip the Tables—Use a Spreadsheet
 Spreadsheets are easier to use. Create the spreadsheet, then paste into Writer.

The spreadsheet looks like this when you paste it into Writer

The spreadsheet looks like this when you paste it 
into Writer, then double-click it. 

Here’s the 
spreadsheet in Calc.
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If you’ve got a lot of numeric data, or things that would be better done in a spreadsheet, then just do 
it in a spreadsheet. Then copy and paste the data into the Writer document. You can copy some or 
all of a spreadsheet. 

When you paste it into Writer, it looks just like plain data; any borders you apply will come over, 
but if there aren’t any borders, you don’t see any. When you double-click in the spreadsheet data in 
Writer, then it looks like a spreadsheet.

Plain Pasting
Copy the part of the spreadsheet you want to copy, then go to the other document and choose Edit 
> Paste to simply paste the spreadsheet.

Linking to the Spreadsheet, for Automatic Updates
Copy the part of the spreadsheet you want, go to the other document, and choose Edit > Paste 
Special. In the Paste Special window, select DDE Link. Click OK. 

That means the pasted information will be updated every time you change the data in the 
spreadsheet. This is particularly nice if you need data from a spreadsheet to be included in several 
different documents. This works when you paste from a spreadsheet into a Writer document, and 
when you paste from a spreadsheet into another spreadsheet.

Formatting Tables
You can format many aspects of a table—the background, borders, border styles, and so on. 
There’s a specific toolbar, the Table toolbar, that helps you do much of that.

Viewing the Table Formatting Bar
When you create a table, there are a bunch of table-specific things you’ll want to do: apply borders, 
add and remove rows and columns, etc. To help you do these things more easily, OpenOffice.org 
provides a specialized table toolbar with these tools. 
1 Click in a table.
2 Be sure that the Table toolbar appears. If 

it doesn’t, choose View > Toolbars > 
Table.
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Adding or Removing Table Borders
Table borders are good for making tables more legible. You can also remove table borders using 
these steps, if you want to use the approach described in Using Tables, Not Tabs, for Parallel 
Columns of Text on page 145.

1 Open the table to apply borders to.

2 Be sure you can see the table formatting toolbar. Refer to Viewing the Table Formatting Bar 
on page 182 if you don’t see it. 

3 Click on the borders icon and hold your mouse down on it. Select the blank option, to clear 
the current borders, before you apply other borders.

Whenever you 
switch where the 
borders are placed, 
you have to clear 
the old borders 
first by selecting the 
blank option. Then 
select a new border 
placement option.
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4 With the table still selected, click and hold down the mouse again on the borders icon and 
select the icon for the formatting you want.

5 The table will show the new border placement.

Applying Different Border Styles
You can set off or distinguish certain lines, such as the heading row, in your table using different 
types of borders, such as double lines or single lines.

1 Select the table to change line styles for.
2 Be sure the table toolbar is displayed. 
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3 Click and hold down your mouse on the Border Style icon.

4 Select a border type you want.
5 The table will reflect the change.

Changing the Border Color
This is very similar to the other procedures. Just select the table and use the line color icon on the 
table toolbar.
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Applying Background Shading
Background shading is another good way to highlight information in a table or make a table with 
lots of columns or rows more readable.

1 Select the table, and be sure you can see the table formatting bar. 
2 Click and hold down the mouse on the Background icon.

3 Select a color.
4 The table will reflect the change.
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Advanced Reference to Borders and Shading 
Let’s say you want a table that looks like this. There are different border widths, border styles, 
and though it doesn’t show in the printed version of the book, different colors, on various lines 
within the table.

Very few people would, of course, since it’s not that attractive. But the point is, how do you 
apply specific border formatting to each border in a table? To have more control over border 
formatting, you’ll want to use the Table Format window. Select the table and choose Table > 
Table Properties.

Borders Tab
You can use the presets but you can also click on each line in the border area. Clicking on a line 
in the User-Defined border area will switch it from selected to deselected 

Give the text some 
spacing using these 
fields.

Specify the border style 
and color here, for the 
currently selected line in 
the User-Defined field, or 
for the selected Default 
borders.

Specify the shadow, direction, and distance from 
the border, here. The shadow is for the whole 
table, not per line.

Click on a line in the User-
Defined area, then select color, 
style, and other options.
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When you select a line in the User-Defined area, or when you choose a preset Default pattern, 
here’s what it translates into in a table.

What about Merge Adjacent Line Styles?  This option in the Borders tab merges two different 
border styles of adjacent cells in a Writer table into one border style. This property is valid for a 
whole table in a Writer document.
The rules can be condensed to the statement that the stronger attribute wins. If, for example, one 
cell has a red border of 2 point width, and the adjacent cell has a blue border of 3 point width, then 
the common border between these two cells will be blue with 3 point width.

Background Tab
This doesn’t provide all that much additional value, but you can apply the formatting to the cell, 
row, or whole table. You can also choose a background color or background graphic for the cell, 
row, or table 

Only the far-left
border

Only the top
border

Only the far-right 
border

Only the bottom
border

All interior 
horizontal borders

All interior vertical
borders
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Adding and Managing Rows and Columns
Once you’ve got the formatting down and you start entering information in the table, you’ll 
probably find that you don’t have enough rows, or you have too many columns here’s how to 
hand that—and as usual, the Table toolbar has the tools you need.

Adding and Deleting Rows and Columns
1 Be sure you can see table toolbar; if you can’t, choose View > Toolbars > Table.
2 Click in the row above where you want a new row. 

3 Click the Insert Row icon

4 Click in the row you want to delete, or select rows to delete, and click the horizontal  icon.

Changing Column Width
You can use the Table Format window to change column width, or drag the borders.

Dragging the Column Borders
1 Select the entire table and position your cursor over the line on the ruler where you want to 

change the width of a column. Make sure the cursor turns into a two-ended arrow, as shown.
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2 Drag the column separator to the left or right to change the width.

This will also work if you move your mouse over the table itself; when the icon looks like this, drag 
the border left or right.

Using the Table Format Window to Change Column Width
1 Select the table.
2 Choose Table > Table Properties.
3 Click the Columns tab.

4 Specify the column widths.
5 Click OK.

Resizing Columns Using the Optimization Icons
Use these tools to automatically make all columns equal in width, or make them all the right width 
for their content (optimal width).
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1 Select the table. 

2 Be sure you can see the table toolbar; if you can’t, choose View > Toolbars > Table. You’ll 
be using the Optimize icon in this procedure, and the options available when you long-click 
on it.

3 You can distribute the columns evenly, or simply optimally for the content. 

To make columns equal, click and hold down on the Optimize icon and select the 
Distribute Columns Evenly icon. The columns will be resized equally.

In the table toolbar, click and hold down on the Optimize icon and select the Optimize 
Width icon. The column widths adjust to the minimum width the need to display all text 
on one line.
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Splitting and Merging Cells
1 Select the cells you want to merge.

2 Click the Merge Cells icon on the table toolbar.

3 The results will look like this.

4 To split cells, click in a row where you’ve already merged cells.

5 Click the Split Cells icon in the table formatting toolbar.
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6 In the resulting window, select the correct number of cells and specify vertical split. Don’t 
just accept the default; it’s usually incorrect

7 Click OK. 

Creating and Applying AutoFormats: The 
Table Formatting Timesaver
Once you’ve formatted a few complex tables, you realize 
that it is a huge time sink. Just applying the formatting once 
can take a long time; how long would it take you to apply 
all the formatting at right, to twenty tables? Longer than 
you want to spend. Luckily, you can save time with 
AutoFormats. AutoFormats are like styles for tables: you 
“freeze” the formatting settings for a table the way you 
want it, and then just apply it quickly to any other table. 
AutoFormats don’t just retain table formatting; they retain 
things like font and font size, as well.
AutoFormats come with you from one document to 
another. They also work the same way in Calc 
spreadsheets.

Creating an AutoFormat
1 Format a table the way you want it to appear.

2 Select the entire table. (In Calc, select at least three cells across and two down.)
3 Choose Table > AutoFormat. (In Calc, choose Format > Autoformat.)

StandardTable Formatting
Borders on horizontal lines only

Borders are 2 pts wide and light 
gray

Dark gray-shaded top line
Black Arial 12 point text in 
heading
Black Times New Roman 10 
point text in body
Numbers have $ and two 
decimal places
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4 The AutoFormat window will appear. In that window, click Add. 

5 In the Add AutoFormat window, type a name for the format. Click OK.

6 Click More. Specify any additional options like number formatting.

7 You’ll see a preview of the autoformat in the AutoFormat window.

8 Click OK. 

Applying an AutoFormat to a Table
Once you’ve created your AutoFormat, you’re ready to apply it to other tables you want to format. 
(You can also, of course, apply any of the existing AutoFormats.) You can also apply an 
AutoFormat when you create a table in the first place; see Creating a Table Using the Table Menu 
on page 179.

1 Open a document and select a table that you want to format. 
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2 Choose Tables > Autoformat. The AutoFormat window will appear.
3 In the Format list, scroll down and select the AutoFormat you want.
4 Click the More button at the right side.
5 Unmark or mark any options you want to change.

6 Click OK.
7 The table will reflect the AutoFormat.

Converting Between Text and Tables
You can do more than create a table; you can convert it from text, or from a spreadsheet.

Converting Text to a Table
The approach we’ve shown so far is to create the table structure, then put in the text. That’s fine 
but what if you’ve already got some text, and you just want it in table format? Luckily, there’s 
the text-to-table conversion feature.
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1 Select the text. The text needs to be separated with tabs or another separator so that Writer can 
tell where the columns will go.

2 Choose Table > Convert > Text to Table.
3 The conversion window will appear. 

4 Select the item that separates the columns, such as a tab, and set other options such as whether 
you want a heading row.

5 Click OK.
6 The text will be converted to a table.
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Converting a Table to Text
This is just the opposite of the previous procedure. Let’s say you’ve got a table full of data and 
you just want it in paragraphs instead. 

1 Select the entire table.
2 Choose Format > Convert > Table to Text.
3 The conversion window will appear. Leave the values as is, or change the separator item.

4 Click OK.

Converting a Table to a Spreadsheet
Copy the table, switch to a spreadsheet, click in one cell of the spreadsheet, and paste. 

Converting a Spreadsheet to a Table
This is simple, in a way. You need to paste the spreadsheet into a Writer document as formatted 
text, then just convert that text to a table.

1 Copy the portion of the spreadsheet that you want to turn into a table.
2 Move to a Writer document.
3 Choose Edit > Paste Special and select Formatted Text. Click OK.

You can also click and hold down on the Paste icon and paste as Formatted Text. 

4 The text will appear as a table, but without borders. Select all the text and the table toolbar 
will appear. Apply a border if you want one on the table. See Adding or Removing Table 
Borders on page 183.
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Automatic Number Formatting 
When you’ve got a big table full of sales figures or prices, it’s a pain to type all those currency 
symbols in by hand. Fortunately, OpenOffice.org will do it for you. 
1 Open the document with the table containing numbers.
2 Select the numbers (not the heading) in the numbers column and right-click on that column. 

Choose Number Format.
3 In the Number Format window, in the Category list, select the number format you want such 

as Currency. Then in the Format list, select the variant that you want. 

4 In the Options area, specify the number of decimal places, if you want to change the default 
settings, and how negatives are displayed.

5 Click OK.
6 The table will reflect the changes.
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Sorting Data in a Table
This process works with plain text lists, as well; however you can only sort by the first word in 
the list.
1 Open the document and select the table, without the headings.

2 Choose Tables > Sort. The Sort window will appear.

3 Be sure that in the Direction area, Rows is selected. You typically want to sort the rows of 
data, so that the rows are re-ordered, so this is correct.
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4 Be sure the Key 1 item is selected. Key 1 just means the first thing to sort by. Then in the 
Column list, type the number of the column you want to sort by. In the example shown earlier, 
if you wanted to sort by price, you would select Column 3.

5 Then choose whether to sort by Alphanumeric or Numeric, and Ascending or Descending. 
You must choose Numeric to sort numbers.

6 If you want to sort by another column now, select Key 2, and select the column and options for 
that sort.

7 Click OK. The data will be sorted.
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If you have problems sorting numbers, select all the number cells, right-click, choose Number 
Format, and be sure that they’re a number or currency format rather than Text. If your numbers 
are left-aligned in the table, they’re not the right format. See Automatic Number Formatting on 
page 198 for more information 

Doing Calculations in Tables
In general, I recommend doing calculations in spreadsheets, then pasting them into your Writer 
document. However, you can also do some calculations in tables.
1 If you want to apply number formatting, see Automatic Number Formatting on page 198.
2 Click in the table, where you want the calculation result to appear.

3 Choose Table > Formula. The formula toolbar will appear.

4 Type the calculation. Use <> around the cell references. The first cell in the first row and 
column is A1, and so on. 

5 Click the check mark icon.
6 The calculation result will appear in the table cell.


